User authentication with Hapi, Passport and Mongoose

Update July 17th, 2014: Travelogue, which we use here, is being discontinued. I was also unable to update the dependencies (Hapi from 3 to 6, for »